Unable to release print jobs when using OSRP

Incident Report for PrinterCloud

Postmortem

Unable to release print jobs when using Offline Secure Release Printing (OSRP)

Introduction:

On April 11, 2025, a subset of customers in the EMEA region encountered difficulties releasing held print jobs through the Control Panel Application (CPA) when the workstation client was offline. The issue was reported at 12:30am CEST, alerting our Product Support, DevOps, and Engineering teams.

Issue Summary: 

During the incident, affected users were unable to release print jobs from the CPA interface. Other release mechanisms, such as the Release and Admin Portals and direct printing, continued to function as expected. The issue was specific to customers utilizing OSRP in conjunction with the CPA, and did not impact broader system functionality.

Root Cause:

A function essential for CPA-based job releases was absent in the latest deployment of a backend service. This issue manifested when testing combined CPA and OSRP specific workflows.

Resolution:

DevOps identified that a service deployment led to unexpected behavior impacting the CPA’s ability to release jobs. Reverting to the previous stable version of the service quickly restored functionality for affected customers and the incident was resolved as of 3:23pm CEST.

Mitigation:

  • Reverting the service to its prior version resolved the issue and restored expected operations. 
  • Subsequent monitoring confirmed that CPA job releases resumed successfully.

Conclusion:

We acknowledge the disruption caused to customers that rely on CPA for job releases. The rollback restored functionality quickly, and follow-up actions are being taken to improve coverage and testing for CPA-specific workflows. We are committed to preventing similar issues in the future and ensuring a reliable and consistent printing experience for all customers.

Posted Apr 11, 2025 - 15:06 MDT

Resolved

This incident has been resolved.
Posted Apr 11, 2025 - 07:23 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 11, 2025 - 07:01 MDT

Investigating

We are currently investigating this issue.
Posted Apr 11, 2025 - 05:01 MDT
This incident affected: PrinterLogic | SaaS Frankfurt (PrinterLogic | SaaS Frankfurt) and PrinterLogic | SaaS North Europe (PrinterLogic | SaaS North Europe).