Customers may be experiencing issues when accessing the platform
Incident Report for PrinterCloud
Postmortem

Introduction:

Customers experienced issues accessing the PrinterLogic platform (US region).‌

Issue Summary: 

On February 9th, between 7:48 AM MST and 8:49 AM MST, a segment of our US instances were not accessible. From 8:17 AM MST until 8:57 AM MST, badge release was not available in the US region. 

Impact: Major outage - Customer instances were not accessible. 

Affected Regions: printercloud.com - US region

Root Cause:

On February 9th, a surge in traffic exposed a DNS misconfiguration, overwhelming select endpoints. Internal Service communication faltered until a rollback had been completed.

Solution and Mitigation:

Engineering teams received automated alerts of the situation and began investigating.

Once identified, DNS configurations were promptly rolled back and propagated across the infrastructure. Instance availability improved between 8:17 AM MST and 8:49 AM MST once propagation completed. Following the resolution of instance availability, a service adjustment was necessary to restore badge release functionality.

The configuration rollback has resolved the Service disruption, and impacted Services are now operating as expected. Teams have reviewed and identified the DNS misconfigurations, with additional measures being implemented to ensure proper operation of the configurations within internal testing environments before rolling them out to customer environments.

Conclusion:

This issue has been resolved.

Posted Feb 12, 2024 - 15:27 MST

Resolved
This incident has been resolved. A postmortem will be published by 5:00 PM MT on Monday, February 12th.
Posted Feb 09, 2024 - 10:05 MST
Monitoring
We have resolved this issue and will continue to monitor for an additional 30 minutes. At the conclusion of the monitoring period, we will resolve this incident. A postmortem will be published by 5:00 PM MT on Monday, February 12th.
Posted Feb 09, 2024 - 09:36 MST
Identified
We have identified the cause of the service disruption and are actively working to stabilize and mitigate any additional impact.
Posted Feb 09, 2024 - 09:05 MST
Update
We are continuing to investigate this issue.
Posted Feb 09, 2024 - 08:50 MST
Investigating
We are experiencing issues when accessing the platform.
Posted Feb 09, 2024 - 08:19 MST
This incident affected: PrinterLogic | SaaS US (PrinterLogic | SaaS, MSP Portal - US).