Incident with PrinterLogic
Incident Report for PrinterCloud
Resolved
This incident has been resolved.
Posted Dec 20, 2023 - 07:25 MST
Monitoring
We have identified the issue and stabilized printercloud.com. We are continuing to monitor.
Posted Dec 20, 2023 - 03:26 MST
Investigating
Instances hosted in the U.S. on printercloud.com may be loading slow or experiencing 400 errors.

We are currently investigating this issue.
Posted Dec 20, 2023 - 03:18 MST
This incident affected: PrinterLogic | SaaS US (PrinterLogic | SaaS, MSP Portal - US).