Incident with PrinterLogic
Incident Report for PrinterCloud
Postmortem

Introduction:

Customers were experiencing issues related to badge and pin authentication on the CPA.‌

Issue Summary:

Impact: Customer instances were experiencing issues with badge and pin authentication on the CPA.

Affected Regions: All Regions

Root Cause:

A code change to the identity service resulted in an outage.

Solution and Mitigation:

Engineering teams were alerted of the situation and began investigating.  It was determined that rolling back the recent change was the best solution to restore services as quickly as possible.  The rollback was complete within 45 minutes of the issue being reported.

Conclusion:

This issue has been resolved. We have implemented additional automated tests to prevent recurrence and are continuing to enhance  our monitoring capabilities.

Posted Feb 02, 2024 - 17:58 MST

Resolved
Customers were experiencing issues related to badge and pin authentication on the CPA.
Posted Feb 02, 2024 - 08:30 MST