US instances intermittently experiencing "400 Bad Request" errors when accessing instance
Incident Report for PrinterCloud
Postmortem

US instances intermittently experiencing "400 Bad Request" errors when accessing Admin Console

Introduction:

On May 16, 2024 between 13:37 MT - 14:03 MT, some customers experienced “400 Bad Request” errors when attempting to access the admin console.

Issue Summary:

Customers affected during the outage were unable to process user login requests, or other core functionality.

Resolution: 

Engineering teams stabilized the environment, determined the cause and deployed a fix to address the high utilization.

Root Cause: 

High utilization contributed to a backlog of requests, and exhaustion of resources.

Solution and Mitigation:

A fix has been deployed in client version 25.0.0.1025

Conclusion:

Customers utilizing client version 25.0.0.1022 must update to version 25.0.0.1025 ASAP

Posted May 21, 2024 - 13:29 MDT

Resolved
This incident has been resolved.
Posted May 16, 2024 - 15:07 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 16, 2024 - 14:17 MDT
This incident affected: PrinterLogic | SaaS US (PrinterLogic | SaaS).