Intermittent issue with uploading drivers: Error occurred creating the driver package

Incident Report for PrinterCloud

Postmortem

Issue Summary:On February 14, 2025, users reported intermittent issues when attempting to upload driver packages. The error message displayed was: "Error occurred creating the driver package."

Root Cause:The issue was identified as a missing query or function in the database, leading to a failed query or incomplete processing during driver package creation. Due to the intermittent nature of the problem, it was not immediately detected during manual testing.

Resolution:We resolved the issue by reverting to a previous version of the code that included the necessary query/function. Additionally, we have incorporated enhanced testing into the build process to validate driver package creation, ensuring all required queries and functions are present in future updates.

Conclusion:We acknowledge the impact this issue had on some customers' ability to use the product as expected. We remain committed to continuous improvement and are proactively working to minimize service disruptions moving forward.

Posted Feb 19, 2025 - 15:12 MST

Resolved

This incident has been resolved.
Posted Feb 18, 2025 - 09:01 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 14, 2025 - 18:56 MST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 14, 2025 - 17:58 MST

Update

We are continuing to investigate this issue.
Posted Feb 14, 2025 - 09:16 MST

Investigating

We are currently investigating this issue.
Posted Feb 14, 2025 - 09:15 MST
This incident affected: PrinterLogic | SaaS US (PrinterLogic | SaaS, MSP Portal - US), PrinterLogic | SaaS Frankfurt (PrinterLogic | SaaS Frankfurt, MSP Portal - Frankfurt), PrinterLogic | SaaS Sydney (PrinterLogic | SaaS Sydney, MSP Portal -Sydney), PrinterLogic | SaaS Canada (PrinterLogic | SaaS Canada, MSP Portal - Canada), PrinterLogic | SaaS North Europe (PrinterLogic | SaaS North Europe, MSP Portal - North Europe), and PrinterLogic | SaaS Singapore (PrinterLogic | SaaS Singapore, MSP Portal - Singapore).