Incident with PrinterLogic
Incident Report for PrinterCloud
Postmortem

Introduction:

On November 9, 2023, customers with instances hosted in the US were unable to utilize PrinterLogic SaaS.

Issue Summary:

Impact: Customers unable to utilize PrinterLogic SaaS between 10:29 AM MST and 10:55 AM MST.

Affected Regions: US

Root Cause:

Our investigation revealed a high number of concurrent transactions on the database servers.

Solution and Mitigation:

The Engineering and DevOps team were able to quickly stabilize the environment, engineering teams are working to minimize concurrent transactions for the affected services.

Conclusion:

We have restored all impacted services, and are working to mitigate this in the future.

Posted Nov 13, 2023 - 18:11 MST

Resolved
This incident has been resolved.
Posted Nov 09, 2023 - 11:32 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 09, 2023 - 11:25 MST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 09, 2023 - 11:09 MST
Investigating
We are currently investigating reports of US instances being unavailable.
Posted Nov 09, 2023 - 10:53 MST
This incident affected: PrinterLogic | SaaS US (PrinterLogic | SaaS, MSP Portal - US).