Incident with PrinterLogic

Incident Report for PrinterCloud

Resolved

This incident has been resolved.
Posted Sep 01, 2023 - 16:26 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 01, 2023 - 03:37 MDT

Investigating

Some customers are experiencing an error when attempting to access the PrinterLogic system. We are investigating this issue.
Posted Sep 01, 2023 - 03:07 MDT
This incident affected: PrinterLogic | SaaS Frankfurt (PrinterLogic | SaaS Frankfurt, MSP Portal - Frankfurt).