Incident with PrinterLogic
Incident Report for PrinterCloud
Postmortem

Introduction:

Customers were experiencing issues related to CPA access. Users were experiencing device freezing\locking symptoms. Customers who were logged in may have experienced issues related to releasing print jobs. 

Issue Summary:

Impact: A subset of customer instances were experiencing issues with the CPA.

Affected Regions: APAC

Root Cause:

During our investigation we determined a recent change to one of our services was utilizing more CPU than expected, which made some services unavailable.

Solution and Mitigation:

Engineering teams were alerted of the situation and began working on a fix which was deployed to production on Friday, September 1, 2023.

Conclusion:

This issue has been resolved. We have implemented mitigating measures to prevent recurrence. Additional environmental monitoring has been incorporated within our internal processes. In the event of any recurrence, we will proactively announce on our Service Status page.

Posted Sep 03, 2023 - 15:31 MDT

Resolved
This incident has been resolved.
Posted Sep 01, 2023 - 16:27 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 30, 2023 - 22:38 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 30, 2023 - 21:51 MDT
Update
We are investigating issues related to CPA access. Users may experience device freezing\locking symptoms. Customer who are logged may experience issues related to release print jobs. We are working to mitigate any impact and will continue to advise when the restoration of services is complete.
Posted Aug 30, 2023 - 20:37 MDT
Investigating
We are currently investigating reports of issues using the CPA.
Posted Aug 30, 2023 - 20:00 MDT
This incident affected: PrinterLogic | SaaS Sydney (PrinterLogic | SaaS Sydney).