US instances intermittently experiencing "400 Bad Request" errors; this is impacting access to the Admin Console, Self-Service Portal, or printing that requires access to AWS
Incident Report for PrinterCloud
Postmortem

Resolution of SaaS Instances intermittently experiencing “400 Bad Request”

Introduction:
On April 4th, a subset of our customers were intermittently experiencing “400 Bad Request” errors impacting access to the Admin Console and Self-Service Portal.

Issue Summary:
Users were unable to access the Admin console and Self-Service Portal during the incident.

Resolution
Engineering teams were able to identify the issue and implement changes which stabilized the environment.

Root Cause
The issue was traced back to an exhaustion of cache at the database level.

Solution and Mitigation:
In response to this incident, Vasion is taking proactive steps to enhance our platform's stability.  These measures are part of our ongoing commitment to providing a reliable and efficient platform to our users.

Conclusion:
We apologize for any inconvenience this may have caused and thank our users for their patience and understanding as we worked through resolving this issue. Your trust in Vasion is important to us, and we are dedicated to ensuring a high level of Service reliability and user satisfaction.

Posted Apr 05, 2024 - 15:04 MDT

Resolved
This incident has been resolved. A postmortem will be provided within 48 hours.
Posted Apr 04, 2024 - 13:49 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 04, 2024 - 12:31 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 04, 2024 - 11:50 MDT
Update
We are continuing to investigate this issue.
Posted Apr 04, 2024 - 11:30 MDT
Update
We are continuing to investigate this issue.
Posted Apr 04, 2024 - 10:30 MDT
Update
We are continuing to investigate this issue.
Posted Apr 04, 2024 - 10:00 MDT
Update
We are continuing to investigate this issue.
Posted Apr 04, 2024 - 09:31 MDT
Update
We are continuing to investigate this issue.
Posted Apr 04, 2024 - 09:00 MDT
Update
We are continuing to investigate this issue.
Posted Apr 04, 2024 - 08:30 MDT
Update
We are continuing to investigate this issue.
Posted Apr 04, 2024 - 08:00 MDT
Investigating
We are currently investigating this issue.
Posted Apr 04, 2024 - 07:34 MDT
This incident affected: PrinterLogic | SaaS US (PrinterLogic | SaaS).