Windows client 25.0.0.1022 causing spike in network traffic

Incident Report for PrinterCloud

Postmortem

Windows client 25.0.0.1022 causing spike in network traffic

Introduction:

On May 14, 2024 development released Windows client version 25.0.0.1022.  This client release has caused a significant spike in network traffic

Issue Summary:

Windows client version 25.0.0.1022 is discovered to be doing a 'full' state check-in every 7.5 seconds even when it has no work to do.  Whether the environment is running Windows client version 25.0.0.1022 or not, customers may still be experiencing latency or brief interruptions when accessing the Admin Console or Self-Service portal.  

Resolution: 

A new Windows client has been released to mitigate the issue

Posted Jun 05, 2024 - 07:50 MDT

Resolved

This incident has been resolved.
Posted Jun 05, 2024 - 07:47 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 20, 2024 - 06:38 MDT

Identified

We are seeing issues with client version 25.0.0.1022, where the client is doing a 'full' state check-in every 7.5 seconds even when it has no work to do. This is causing a significant increase in traffic. Please update clients to version 25.0.0.1025 to mitigate this issue as soon as possible.
Posted May 17, 2024 - 15:02 MDT
This incident affected: PrinterLogic | SaaS US (PrinterLogic | SaaS), PrinterLogic | SaaS Frankfurt (PrinterLogic | SaaS Frankfurt), PrinterLogic | SaaS Sydney (PrinterLogic | SaaS Sydney), PrinterLogic | SaaS Canada (PrinterLogic | SaaS Canada), PrinterLogic | SaaS North Europe (PrinterLogic | SaaS North Europe), and PrinterLogic | SaaS Singapore (PrinterLogic | SaaS Singapore).