Admin Console not responding
Incident Report for PrinterCloud
Postmortem

Introduction:

On March 11th, it was determined across a subset of our customers' instances, where interactions with menu dropdowns, tabs, and opt-in modals were unresponsive after login.  

Issue Summary:

Users experienced clicking on items without any results or actions being executed, impacting the usability of our Service.

Resolution

The problem was resolved without the need for intervention from our internal teams. Normal service behavior has been restored, and all functionalities are operating as expected.

Root Cause

The issue was traced back to a code error within a third-party system that we rely on. This error led to faulty JavaScript execution, disrupting user interface interactions. The third-party vendor acted swiftly to address and patch the code error, which in turn resolved the issues within our platform.

Solution and Mitigation:

In response to this incident, Vasion is taking proactive steps to enhance our platform's stability. We are implementing additional safeguards to minimize the risk of third-party dependencies affecting our Service quality. These measures are part of our ongoing commitment to providing a reliable and efficient platform to our users.

Conclusion:

We apologize for any inconvenience this may have caused and thank our users for their patience and understanding as we worked through resolving this issue. Your trust in Vasion is important to us, and we are dedicated to ensuring a high level of Service reliability and user satisfaction.

Posted Mar 13, 2024 - 13:40 MDT

Resolved
This incident has been resolved. Post mortem will be provided within 48 hours.
Posted Mar 11, 2024 - 20:28 MDT
Monitoring
Instances are now working and we are monitoring to confirm the issue is resolved
Posted Mar 11, 2024 - 20:00 MDT
Update
We are continuing to investigate this issue.
Posted Mar 11, 2024 - 19:23 MDT
Investigating
We are currently investigating this issue.
Posted Mar 11, 2024 - 19:05 MDT
This incident affected: PrinterLogic | SaaS US (PrinterLogic | SaaS), PrinterLogic | SaaS Frankfurt (PrinterLogic | SaaS Frankfurt), PrinterLogic | SaaS Sydney (PrinterLogic | SaaS Sydney), PrinterLogic | SaaS Canada (PrinterLogic | SaaS Canada), and PrinterLogic | SaaS North Europe.