US instances experiencing "404 page not found" errors when accessing instance (Admin Console, Self-service portal, release portal)
Incident Report for PrinterCloud
Postmortem

Introduction:

On October 23, 2024 between 5:45 AM and 7:12 AM MT, customers experienced 4XX status codes sporadically when accessing services in the US.

Issue Summary:

Infrastructure connectivity issues resulted in services being unable to communicate.

Resolution: 

Once connectivity issues were identified, the affected infrastructure was promptly isolated away from customer traffic.

Root Cause: 

During morning scaling, a portion of infrastructure experienced connectivity issues preventing services from communicating with each other.

Solution and Mitigation:

After the affected infrastructure was isolated, we observed the error rates experienced by customers clear out.

Additional monitors are being implemented to proactively identify this issue. We will continue to investigate the circumstances of this issue to prevent this issue from recurring in the future.

Conclusion:

We recognize this had an impact for our US customers during the start of the business day. We are committed to enhancing our monitoring and architecture to ensure better service availability. We thank you for your patience as we worked through this service disruption.

Posted Oct 25, 2024 - 06:59 MDT

Resolved
This incident has been resolved.
Posted Oct 23, 2024 - 08:10 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 23, 2024 - 07:35 MDT
Update
We are continuing to investigate this issue.
Posted Oct 23, 2024 - 07:15 MDT
Investigating
We are currently investigating this issue.
Posted Oct 23, 2024 - 06:35 MDT
This incident affected: PrinterLogic | SaaS US (PrinterLogic | SaaS).