Instances using Off Network Printing experiencing latency in jobs printing
Incident Report for PrinterCloud
Postmortem

Instances using Off Network Printing experiencing latency in jobs printing

Introduction:

From August 27, 2024 6:00 pm MDT through August 28, 2024 7:30 am MDT a subset of customers may have experienced latency of up to 15 minutes when using Off Network printing.  

Issue Summary:

Customers affected during the period of degraded performance experienced delays up to 15 minutes between sending and printing of off-network jobs. Compounding this issue was the appearance that the off-network gateways were offline.

Resolution:

The service was rolled back to the previous version.

Root Cause: 

A proven working version was rolled out, that had unforeseen issues in a multi-regional environment, and had to be rolled back

Solution and Mitigation:

We updated our Off-Network service back to the previously known working version. We are improving the suite of multi-regional testing in our pipelines.

Conclusion:

We recognize that Off-Network printing is part of critical printing infrastructure for many customers. We understand that even degraded performance has a significant impact on business operations. We thank you for your patience as we worked through this service disruption.

Posted Sep 03, 2024 - 15:05 MDT

Resolved
This incident has been resolved.
Posted Aug 28, 2024 - 08:30 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 28, 2024 - 07:51 MDT
Update
We are continuing to investigate this issue.
Posted Aug 28, 2024 - 07:23 MDT
Update
We are continuing to investigate this issue.
Posted Aug 28, 2024 - 07:22 MDT
Investigating
We are currently investigating this issue.
Posted Aug 28, 2024 - 06:38 MDT
This incident affected: PrinterLogic | SaaS US (PrinterLogic | SaaS), PrinterLogic | SaaS Frankfurt (PrinterLogic | SaaS Frankfurt), PrinterLogic | SaaS Sydney (PrinterLogic | SaaS Sydney), PrinterLogic | SaaS Canada (PrinterLogic | SaaS Canada), and PrinterLogic | SaaS Singapore (PrinterLogic | SaaS Singapore).