PrinterLogic - Badge Issues
Incident Report for PrinterCloud
Postmortem

Introduction:

On October 12, 2023, a subset of our customers experienced issues with their badges and/or pins not being recognized during authentication requests. This resulted in the inability to authenticate, with the only workaround being to re-register the impacted badges.

Issue Summary:

Impact: A subset of customer instances experienced errors upon login with a badge.

Affected Regions: All regions

Root Cause:

Our in-depth review revealed that a data cleanup script was the source of the issue. Customers who use badges for authentication and rely on specific user attribute data for authentication were impacted due to the data being incorrectly deleted for some of their users during the data cleanup script execution.

Solution and Mitigation:

The Engineering and DevOps teams worked to restore all impacted user badge attribute data and as of October 19, 2023, at 10:41 AM MDT, all known impacted user records had been restored. If any customer observes continuing issues when trying to authenticate with a badge, the impacted badge should be re-registered.

Conclusion:

This issue has been resolved. We have restored all impacted user data and implemented additional testing measures to prevent recurrence.

Posted Oct 23, 2023 - 16:34 MDT

Resolved
We have identified and proactively resolved issues related to customer's badges and pins data. If a user is still experiencing technical issues, customers should attempt to reregister affected badges. If the results are unsuccessful or if this is not a viable option, please contact Product Support at support@printerlogic.com or call:

North America................................+1 (435) 652-1288, ext. 2
Germany.........................................+49 (6122) 7783900
United Kingdom.............................+44 (20) 39003233
France.............................................+33 (1) 85640227
Netherlands....................................+31 (10) 7986140
Australia.........................................+61 (2916) 12828


A postmortem will be available October 23rd.
Posted Oct 19, 2023 - 19:10 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 19, 2023 - 10:41 MDT
Update
We continue to work towards full restoration of badging and pin functionality. We appreciate your patience and regret any impact to our customers.
Posted Oct 18, 2023 - 20:10 MDT
Update
We continue our efforts to resolve these issues and are treating with priority and urgency. We will continue to provide additional updates as we work to mitigate any impact.
Posted Oct 16, 2023 - 08:51 MDT
Update
We continue to work towards full restoration of badging services. We appreciate your patience and regret any impact to our customers.
Posted Oct 13, 2023 - 12:26 MDT
Identified
We have identified the cause and are working to mitigate any further impact. This only affects a small subset of our customers utilizing Badge Management. We will continue to provide updates as new information becomes available.
Posted Oct 12, 2023 - 16:36 MDT
Investigating
Some users may encounter an error when attempting to badge in and may see an error stating the badge is not recognized. We are currently investigating. As a temporary workaround, users can manually re-register their badges
Posted Oct 12, 2023 - 15:53 MDT
This incident affected: PrinterLogic | SaaS US (PrinterLogic | SaaS), PrinterLogic | SaaS Frankfurt (PrinterLogic | SaaS Frankfurt), PrinterLogic | SaaS Sydney (PrinterLogic | SaaS Sydney), and PrinterLogic | SaaS Canada (PrinterLogic | SaaS Canada).